Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2759 closed problem (fixed)

Tooltips undefined for procedures in CPT folder

Reported by: tmcmahon Owned by: mhoag
Priority: major Milestone: heron-hackberry-update
Component: data-repository Keywords: public-web
Cc: dconnolly, mhoag, ngraham, vleonardo Blocked By:
Blocking: 2793 Sensitive: no

Description

The tooltips for items within the Metathesaurus CPT Hierarchical Terms folder are missing. When hovering over an item, the tooltip states "undefined."

Change History (11)

comment:1 Changed 3 years ago by dconnolly

  • Sensitive unset
  • Type changed from task to problem

To some extent, this is a dup of #26; it's at least a known problem.

This issue affects other GPC sites, so I'd rather not treat it as sensitive.

comment:2 Changed 3 years ago by ngraham

  • Owner changed from ngraham to mhoag
  • Status changed from new to assigned

Dan notes the right answer is to rebuild the concepts using UMLS.

comment:3 Changed 3 years ago by mhoag

  • Cc ngrahaim vleonardo added

comment:4 Changed 3 years ago by mhoag

  • Blocked By set to 26
  • Cc ngraham added; ngrahaim removed

The code concept_tooltips.sql#L19 indicates that tooltips are *intentionally* turned off for Metathesaurus CPT Hierarchical Terms. It also notes a dependency on #26 before tooltips turned back on.

Setting #26 as blocking.

I guess we will need to take #26 out of the v.Next graveyard.

comment:5 Changed 3 years ago by mhoag

  • Status changed from assigned to accepted

It is unclear to me whether #26 is an actual dependency anymore. I am considering just adding Metathesaurus CPT Hierarchical Terms back to the tooltip construction and seeing if any additional dependencies exist. Building and enhancing concepts is relatively cheap in my mind and it could easily be reversed if an issue arises.

comment:6 Changed 3 years ago by mhoag

  • Blocking set to 2793

comment:7 follow-up: Changed 3 years ago by mhoag

  • Blocked By 26 deleted

Nathan and I went over this and no longer believe that it is necessary to fix #26, in order to fix this issue.

For some reason that neither Nathan or I can recall we explicitly excluded building the tooltips for the CPT Hierarchy. After digging through #26 and #1780, the reason is not immediately apparent and we believe that it may be in error.

The fix (f49c3dc0e9db, 9e0a36f63bbe) works on nightly and since it is the concept dimension there is no reason to believe that it will not work on production.

There is a snag though. After the fix it became apparent that the SQL test source:heron_load/concept_tooltips.sql#L189 does not appear to be functioning as desired (i.e. the test was not catching some concepts that were missing tooltips and didn't have ancestors that were hidden). I am going to invest a little bit of time to see if I can fix/understand this issue before closing this ticket.

comment:8 in reply to: ↑ 7 Changed 3 years ago by mhoag

Replying to mhoag:

There is a snag though. After the fix it became apparent that the SQL test source:heron_load/concept_tooltips.sql#L189 does not appear to be functioning as desired (i.e. the test was not catching some concepts that were missing tooltips and didn't have ancestors that were hidden). I am going to invest a little bit of time to see if I can fix/understand this issue before closing this ticket.

After closer inspection, the test, I believe actually functions as designed. It threw both Nathan and I off originally because when we removed the exception from heron_load/concept_tooltips.sql@3151#L181 missing tooltips table the test still passed, and we believed it should not have. Upon closer inspection, I found that the exception was not needed in the first place because all of the concepts missing a tooltip had "\i2b2\Procedures\PRC\" in their path which is a hidden concept, thus pass the test as designed.

The problem then becomes that there are certain cases where you can have a hidden element/folder in the concept hierarchy, BUT its children are still visible in i2b2. Procedures appears to be one of these special cases. It is unclear to me whether this test should be aware of such cases, but I am definitely leaning towards "no".

comment:9 Changed 3 years ago by mhoag

test ETL passed on the final change for the fix (8f759b850a8b). Merging to the hackberry branch in preparation for concepts load and enhance concepts. Closing as fixed.

comment:10 Changed 3 years ago by mhoag

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:11 Changed 3 years ago by mhoag

  • Keywords public-web added
Note: See TracTickets for help on using tickets.