Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3458 closed enhancement (fixed)

identified data with MRN only; no contact info

Reported by: vleonardo Owned by: mhoag
Priority: major Milestone: heron-jamestown-update
Component: data-repository Keywords: data-builder public-web
Cc: dconnolly, mhoag Blocked By:
Blocking: 2728, 2940 Sensitive: no

Description

Case 2 "Identified for analysis/qi/chart review " from ticket:2728#comment:58 seems separable from the others.

Dan, reporting for Vince, based on today's meeting

Reproduction/Validation

  1. Go to nightheron.kumc.edu
  2. run a DUA on any patient set
  3. Run dua2redcap-NG to generate the .csv data request
  4. Reference the patient table (*-patient.csv)

Expected Results: Patient table has one and only one column (MRN) that has identified information.

A comparative analysis could also be done by running the same reproduction steps with heron.kumc.edu and comparing the columns from the DEID and ID patient tables.

Change History (11)

comment:1 Changed 2 years ago by dconnolly

comment:2 Changed 2 years ago by mhoag

  • Owner changed from mhoag to dconnolly
  • Status changed from new to assigned

Changed both dfbuilder.py and edc_summary to only consider the MRN when doing identified requests. successful build. Ready for review then deployment.

Dan do you have a little time to look this over? (If not assign it back to me)

  1. [6fe0cb1802d7/heron_extract] Remove identified columns in patient dim sans MRN (#3458)

comment:3 Changed 2 years ago by dconnolly

  • Owner changed from dconnolly to mhoag

Getting rid of date_shift surprised me a little, but I guess it's OK.

Looks good to me.

comment:4 Changed 2 years ago by mhoag

  • Resolution set to fixed
  • Status changed from assigned to closed

Deployed the new code
extract ran okay and patient dimension has the columns we would expect:

~/heron> sqlite3 heron-367.db
sqlite> select * from patient_dimension limit 5;
patient_num|vital_status_cd|birth_date|death_date|sex_cd|age_in_years_num|language_cd|race_cd|marital_status_cd|religion_cd|zip_cd|statecityzip_path|income_cd|download_date|import_date|sourcesystem_cd|upload_id|mrn

ran edc_summary looked in the csv and saw MRNs and saw no other identified columns.

Closing.

comment:5 Changed 2 years ago by mhoag

  • Blocking changed from 2728 to 2728, 2940

comment:6 Changed 2 years ago by mhoag

comment:7 Changed 2 years ago by mhoag

comment:8 Changed 2 years ago by mhoag

  • Milestone changed from heron-quivira-update to heron-jamestown-update

This couldn't be validated due to issues with #3533. Moving to the next release to be validated.

comment:9 Changed 2 years ago by ngraham

  • Keywords public-web added

comment:10 Changed 2 years ago by badagarla

  • Sensitive unset

We got permission during heron-weekly from team and documented it in ticket:3557#comment:7.

comment:11 Changed 2 years ago by badagarla

Note: See TracTickets for help on using tickets.